Container Messages (pas d'articles dans la catégorie)

Plus d'informations
il y a 1 an 10 mois #148 par Bernard Perret
Bonjour
j'utilise la template admaireV3, j'ai des menus qui pointent sur Articles > Blog d'une catégorie
Cette catégorie ne comporte pas d'articles car j'utilise un module de news !
J'ai désactivé l'option Messages d'Alertes, mais la div est toujours présente
Je n'ai pas ce problème sur d'autres sites avec des templates différentes ! Avez-vous une solution

Merci
Plus d'informations
il y a 1 an 10 mois #150 par Support technique
Bonjour M. Perret,

La div est en effet présente pour afficher les messages, mais aussi les différents composants (Joomla Content, K2, Joomlannuaire ... ) qui sont généralement chargés depuis un lien de menu.
Nous avons quand même apporté une légère modification au template pour que celle-ci ne soit plus visible dans des situations comme celle que vous venez de nous présenter.
Vous pouvez télécharger la nouvelle version du template depuis votre espace client puis l'installer depuis l’administration de Joomla ou simplement remplacer le fichier index.php du template avec votre client FTP.

Bien cordialement,
Plus d'informations
il y a 1 an 10 mois #151 par Bernard Perret
Bonjour
Merci pour cette rapide réaction, j'ai bien remplacé le fichier index.php de la template, mais la div est toujours présente !
Cordialement
Plus d'informations
il y a 1 an 10 mois - il y a 1 an 10 mois #152 par Support technique
Nous venons de faire un essai avec la même configuration, soit un blog sans aucun article.
Effectivement, il ne sera pas possible de supprimer cette div, puisqu'elle contiendra automatiquement une balise enfant (<section class="blog">) du composant, nécessaire au bon fonctionnement de Joomla.
L'affichage que vous essayez d'obtenir est très particulier, une solution serait peut-être de modifier les styles CSS de l'id #main-box, en enlevant la bordure et les padding Top et Bottom.

Les autres templates que vous utilisez doivent certainement avoir un background de la même couleur que la zone des composants, c'est pour cela que vous ne voyez pas la balise en question.

Cordialement
Dernière édition: il y a 1 an 10 mois par Support technique.
Plus d'informations
il y a 1 an 10 mois #153 par Bernard Perret
re-Bonjour
Je vais gérer d'une autre manière ! merci

autre problèmes :
dans le footer : zone d'information 2 : à chaque fois que l'on supprime du texte il revient, d'autre part il n'est pas possible d 'insérer du code html comme sur la zone d'information 3 ! serait-il possible d'avoir la zone 2 comme la zone 3 ?
Merci
Plus d'informations
il y a 1 an 10 mois #155 par Support technique
Bonjour,

Si vous souhaitez avoir la même configuration entre les deux zones, vous allez devoir modifier le fichier "templateDetails.xml" disponible à la racine du template.

Remplacez la ligne 410 par :
<field name="info1bloc1footer" type="textarea" label="TPL_ADMAIRIEV3_FIELD_INFO1BLOC2FOOTER_LABEL" default="" filter="raw"/>

Et la ligne 412 par :
<field name="info2bloc2footer" type="textarea" label="TPL_ADMAIRIEV3_FIELD_INFO2BLOC2FOOTER_LABEL" default="" filter="raw"/>

L'attribut "default" vierge, vous permettra de laisser le champ vide après enregistrement, quant à l'attribut "filter", il vous permettra d'ajouter du HTML dans la zone de texte.

Pour information, les numéros des lignes peuvent changer en fonction de votre éditeur, utilisez alors la fonction de recherche avec " info1bloc1footer " et " info2bloc2footer" pour les retrouver plus facilement.
Si vous ne souhaitez pas modifier le fichier xml, vous pouvez aussi utiliser la barre d'espace dans la zone de texte pour que celle-ci n'enregistre pas de contenu.

Cordialement
Modérateurs: Support commercialSupport techniqueSupport technique
Temps de génération de la page : 1.195 secondes